Klusters on Ubuntu 12.04

Klusters is an old but efficient and powerful tool for visualizing sorted spikes. Unfortunately it can be a real pain to install on modern distributions. Fortunately a deb package is now available to spare you the pain of installing from source, but since it depends on some ancient KDE and QT libraries, it requires some workarounds to make it work on a current OS.

Instructions:

Go to http://packages.ubuntu.com/natty/kdelibs4c2a
Download the following packages and install with Ubuntu Software
Center (or whatever)
* libavahi-qt3-1
* kdelibs-data_3.5.10.dfsg.1
* kdelibs4c2a
Then install the klusters deb from sourceforge. I used the Ubuntu one for AMD64.
Comments